Çözüldü3.74K görüntülenmeLoraLora 20d
0

2 istasyon şeklinde 20 d modeliyle veri alıp gönderebiliyorum hiçbir sorun yok. Ancak arduino nano her veri gönderdiğinde , kendisine bağlı olan servo motoru hareket ettiriyor. Tüm pinleri denedim aynı sonucu verdi.

Bağlantı şu şekilde = >  Arduino nano – Servo motor(digital pins) besleme dışarıdan 5v – Lora 20d besleme nano’dan 5v.
Araştırdığım forum sitelerinde genelde 2 istemcinin de aynı kütüphaneyi kullanabileceğinden veya nano’nun veri gönderirken pwm pinine yanlış frekans göndermesinden kaynaklı olabilir denmiş, ancak servoyu pwm pininde dahi kullanmazken aynı sonucu alıyorum.

Sizce bu sorunu nasıl çözebilirim ? Zamanınız için teşekkür ederim.

Soru yeni cevaplara kapalıdır.
Mehmet En iyi cevap olarak seçildi Haziran 4, 2021
0

hocam video dan tam anlaşılmıyor ama sanki servo bağlantıları yanlış. kod ve bağlantı şemasını gönderebilir misin.

Servo bağlantısı şu şekilde olmalıdır.

Sarı =  Sinyal

Turuncu / Kırmızı = 5V

Kahverengi = ortak GND (yani harici besleme varsa arduinonun gnd si ile birleştirilmeli)

örnek bir yazı

14 – Servo Motor Kullanımı

Tolunay Akkoyun Yeni yorum gönderildi Haziran 4, 2021

Bağlantılarda bir hata yok @Mehmet bey acemi değilim 🙂 Sanırım kütüphane de bir sorun var servonun bir başka kütüphanesini deneyeceğim.

7 cevaptan 1'ini inceliyorsun, tüm cevapları görmek için buraya tıklayın.
Whatsapp'tan Yaz
1
Ürün Danışmanı Burada!
fixaj.com Ürün Danışmanı
Merhaba,

Ben sadece "Satın Alma" konularında destek vermekteyim.

Kodlama yardımı, haberleşme hataları, bağlantı şemaları vb. konularla ilgili "Soru&Cevap" https://fixaj.com/sorucevap/ sayfamızı ziyaret edebilirsiniz.